[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Probleme de conf wireless...



Bonjour,

mon objetif est de connecter deux pc au moyen d'une connection wireless.
Je sais que les deux cartes fonctionnent (je peux les utiliser pour me
connecter a internet directement sur une livebox).

Impossible de faire un ping... Les deux cartes sont à base Atheros et du
drivers madwifi (version récente, samedi ou dimanche).

Ou est la probleme dans ma conf ?

Conf du premier :
  - carte PCMCIA : netgear WG511T
  - kernel 2.6.11

$ cat /etc/network/interfaces

iface ath0 inet static
    address 192.168.1.1
    netmask 255.255.255.0
    wireless_essid Tinou_Home
    wireless_mode ad-hoc
    wireless_rate 24M
    wireless_channel 11
    wireless_enc off


$ dmesg | grep ath0
ath0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
ath0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps
24Mbps 36Mbps 48Mbps 54Mbps
ath0: turboG rates: 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
ath0: H/W encryption support: WEP AES AES_CCM TKIP
ath0: mac 5.9 phy 4.3 radio 4.6
ath0: Use hw queue 1 for WME_AC_BE traffic
ath0: Use hw queue 0 for WME_AC_BK traffic
ath0: Use hw queue 2 for WME_AC_VI traffic
ath0: Use hw queue 3 for WME_AC_VO traffic
ath0: Use hw queue 8 for CAB traffic
ath0: Use hw queue 9 for beacons
ath0: Atheros 5212: mem=0x21000000, irq=11
ath0: no IPv6 routers present

$ ifup ath0
$ route

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use
Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 ath0

Conf du second pc :
  - carte pci : DWL-520
  - kernel 2.6.12

$ cat /etc/network/interfaces

iface ath0 inet static
  address 192.168.1.2
  netmask 255.255.255.0
  wireless_essid Tinou_Home
  wireless_mode ad-hoc
  wireless_rate 24M
  wireless_channel 11
  wireless_enc off

$ dmesg | grep ath0

ath0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
ath0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps
24Mbps 36Mbps 48Mbps 54Mbps
ath0: mac 5.9 phy 4.3 radio 4.6
ath0: 802.11 address: 00:0f:b5:a0:f4:0f
ath0: Use hw queue 0 for WME_AC_BE traffic
ath0: Use hw queue 1 for WME_AC_BK traffic
ath0: Use hw queue 2 for WME_AC_VI traffic
ath0: Use hw queue 3 for WME_AC_VO traffic
ath0: Atheros 5212: mem=0x21000000, irq=11
ath0: no IPv6 routers present

$ ifup ath0
$ route

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use
Iface
192.168.1.0     *               255.255.255.0   U     0      0        0 ath0

$ ifconfig ath0         
inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::20f:b5ff:fea0:f40f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16772 errors:2148 dropped:0 overruns:0 frame:2148
          TX packets:14858 errors:1 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:200
          RX bytes:13883553 (13.2 MiB)  TX bytes:1169716 (1.1 MiB)
          Interrupt:11 Memory:e1320000-e1330000

$ iwconfig ath0
ath0      IEEE 802.11g  ESSID:"Tinou_Home" 
          Mode:Ad-Hoc  Frequency:2.462 GHz  Cell: 02:0F:3D:AF:53:66  
          Bit Rate=24 Mb/s   Tx-Power:18 dBm   Sensitivity=0/3 
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=36/94  Signal level=-59 dBm  Noise level=-95 dBm
          Rx invalid nwid:59594  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1  Invalid misc:1   Missed beacon:0

Merci d'avance
Etienne



Reply to: