[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problème de mise à jour



Xavier MOGHRABI a écrit :
> Bonjour
> 
> suite à l'annonce de sécurité concernant les paquets d'XFree86, j'ai essayé de 
> mettre à jour un serveur en utilisant apt-get.
> 
> J'obtiens l'erreur suivante lorsque je fais 'apt-get  dist-upgrade' :
> 
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Calculating Upgrade... Done
> 1 packages upgraded, 0 newly installed, 0 to remove and 0  not upgraded.
> Need to get 547kB of archives. After unpacking 0B will be used.
> Do you want to continue? [Y/n] y
> Get:1 http://security.debian.org stable/updates/main xfree86-common 
> 4.1.0-16woody6 [547kB]
> Fetched 547kB in 0s (1198kB/s)
> (Reading database ... 34747 files and directories currently installed.)
> Preparing to replace xfree86-common 4.1.0-16woody5 
> (using .../xfree86-common_4.1.0-16woody6_all.deb) ...
> Unpacking replacement xfree86-common ...
> dpkg: error 
> processing /var/cache/apt/archives/xfree86-common_4.1.0-16woody6_all.deb 
> (--unpack):
>  trying to overwrite `/usr/lib/X11', which is also in package lgtoclnt-ira
> Errors were encountered while processing:
>  /var/cache/apt/archives/xfree86-common_4.1.0-16woody6_all.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> 
> 
> Est-ce que quelqu'un saurait pourquoi ça plante ?
> 
> Merci pour votre aide
> 

Salut, bon ben le fichier incriminé se trouve dans deux paquetages et
donc apt refuse d'écraser une version avec une autre.
Hormis le fait que, sous Sid, aucune trace de ce paquet lgtoclnt-ira, tu
peux forcer l'installation de ton paquet.
Pour cela faire :
cd var/cache/apt/archives/
dpkg -i --force-a xfree86-common_4.1.0-16woody6_all.deb
mais tu vas donc forcer l'écrasement, mieux vaut savoir ce que tu
veux/fait. Et puis si ce lgtoclnt-ira est inconnu par apt-cache c'est
que tu dois l'avoir obtenu par une source particulière, tu devrais donc
savoir  à quoi il sert et si tu peux remplacer ses fichiers par ceux de
xfree86-common.
Un petit dpkg --force-help t'en dira plus sur les options de forçage de
dpkg.
Bonne journée, Fab.



Reply to: