[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

problème apt-get



Bonjour,

J'ai un probleme en utilisant apt-get, que voici. Tout d'abord, je
tourne sur une version hybride de Debian : stable/unstable. 

Lors d'un "apt-get upgrade", tout se passe bien. Aucune erreur.
Néanmoins, apt-get ne fonctionne plus par après, me renvoyant le message
d'erreur : 

Reading Package Lists... Error!
E: Unable to parse package file /var/lib/dpkg/status (1)
E: The package lists or status file could not be parsed or opened.

Aucun problème de droit, ni rien de tout cela avec le fichier status ... 

Le problème est soluble en remplaçant le fichier /var/lib/dpkg/status
par un ancien, un backup de la veille, par exemple.

Ce problème est parfaitement reproductible. La solution fournie me
permet d'utiliser à nouveau apt-get, mais une fois l'upgrade effectué à
nouveau, cela ne fonctionne de nouveau plus ... 

Questions : 

- Pourquoi ce comportement ? Si quelqu'un sait me l'expliquer, je suis
  preneur. J'aimerais surtout me sortir de ce problème ... 

- Je ne suis pas habitué à ces listes. Si je me suis trompé d'endroit,
  merci de me corriger et de me dire ou poster mon message. 

- Merci aussi de me garder en CC: dans les réponses, car je ne suis pas
  abonné à cette liste. 

Voici la liste des nouveaux paquets installés, tous unstable : 
alsa-base apache apache-common apache-utils fontconfig initscripts
libavcodec1 libc6 libc6-dev libopencdk8 libprinterconf0 libwine libxslt1
locales mplayer-686 openoffice.org openoffice.org-bin
openoffice.org-debian-files pconf-detect php4 vorbis-tools wine 
      
Sauf erreur de ma part, aucun ne porte sur ce fichier status ... 



Merci d'avance pour vos réponses ! 

-- 
Marc Demlenne 
GPG : 768FA483 (www.keyserver.be)



Reply to: