[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problème d'activation BootSplash + Framebuffer



le Fri, 19 Sep 2003 14:14:29 +0200, "Fievet Fabien"
<skywalker.mentat@wanadoo.fr> s'exprima en ces termes:

> Bonjour,
> 
> j'ai tenté hier l'installation d'un bootsplash + framebuffer sur ma
> debian Woody.
> 
> Pour cette installation, j'ai suivis le guide de cedric lignier :
> http://cedric.lignier.free.fr/guide-debian/html/jbootsplash.html
> 
> Ayant fait l' installation de ma debian suivant le guide d' Alexis
> Delattre:
> http://www.via.ecp.fr/~alexis/formation-linux/formation-linux.html
> j'ai du changer de noyau (2.4.18 pour aller 2.4.21 comme dans le guide
> de cedric lignier) avant de le recompiler.
> 
> A priori, après avoir suivie toutes les indications pour installer le
> framebuffer et le bootsplash je n'ai aucun message d'erreur.
> 
> J'installe donc un theme pour le bootsplash (j'ai aussi testé avec un
> autre pour etre sur que celui du guide n'est pas en cause), je suis
> les indications, modifie mon lilo et toujours pas de message d'erreur.
> 
> Je me dis cool ça va marcher mais non :( 
> Je suis toujours sur un demarrage classique. Seul point positif il
> détecte les 2 processeurs logiques de mon P4 C maintenant :)
> 
> A priori le framebuffer est activé puisque lorsque je fais un "dmesg |
> less " j'ai des informations indicant son fonctionnement.
> 
> Si vous avez une idée, des suggestions ou un conseil je suis preneur, 

Chez moi ça marche bien (kernel 2.4.21, patch bootsplash de chez Con
Kolivas (http://members.optusnet.com.au/ckolivas/kernel), doc de chez
bootsplash.org, thème custom).

Quelques pistes: 
1) le bootsplash utilise un initrd: l'as tu spécifié à ton bootloader
(config de grub chez moi):	

title Linux SS800
        root (hd0,0)
        kernel /boot/vmlinuz root=/dev/hda1 splash=silent vga=788
pci=biosirq video=vesafb:ypan 
	initrd /boot/initrd.splash.800x600
	boot

2) le bootsplash est destiné, pour les thèmes les plus répandus, à du
FB 1024x728: quelle résolution (vga=?) passes-tu en paramètre au kernel
?
3) enfin, bootsplash est-il vraiment activé: 
	bash-2.05b$ less /usr/src/linux/.config | grep SPLASH
	CONFIG_FBCON_SPLASHSCREEN=y

à tout hasard, chez moi au boot j'ai:

[SNIP]
Kernel command line: root=/dev/hda1 splash=silent vga=788 pci=biosirq
video=vesafb:ypan bootsplash: silent mode.
Initializing CPU#0
[SNIP]

/N 
______________________________________________________________________
Nicolas Rueff <n.rueff@tuxfamily.org>
http://rueff.tuxfamily.org
+33 6 77 64 44 80
--
If a group of N persons implements a COBOL compiler, there will be
N-1 passes.  Someone in the group has to be the manager.
		-- T. Cheatham
______________________________________________________________________

Attachment: pgpkC5LJEaWUU.pgp
Description: PGP signature


Reply to: