[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Debian]:Re: [Debian]:[Distri] Begriffsverwirrung: slink/potato/woody =? stable/frozen/unstable



* Stefan Hofmann <stefan@luci.saar.de> wrote:
> Liebe Liste,
> 
> mal eine ganz doofe Frage (zu der ich keine _klare_ und _eindeutige_
> Quelle gefunden habe):
> 
> Debian 2.1 == slink == stable
>     ok, das ist mir klar
> 
> Debian 2.2 == potato == ?
>     das wird die naechste. Ist das jetzt frozen oder unstable?

Ist momentan frozen, wird bald stable.

> und was ist woody?
> ist das die unstable, als quasi >= potato.

Jepp, das ist die kommende 2.3 und momentan unstable.

> Ich blicke da nicht ganz durch und finde auch, dass die sonst so
> vorbildliche Transparenz bei Debian da etwas fehlt. In den Docs und
> aufm Server ist immer nur von stable/unstable/frozen die Rede - welche
> Distri sich letztendlich dahinter verbirgt, konnte ich nicht finden.

Dann gugg dir mal an wohin die stable, unstable und frozen Links auf
den FTP Servern zeigen:

lrwxrwxrwx   1 root     root            6 Jun 12 00:19 frozen -> potato/
lrwxrwxrwx   1 root     root            5 Jun 12 00:19 stable -> slink/
lrwxrwxrwx   1 root     root            5 Jun 12 00:19 unstable -> woody/

> Die meisten Pakete in unstable und frozen sind symlinks, Unterschiede
> sind relativ selten.

Noch ist woody recht jung, und von vielen Packeten gibt es eben noch
keine spezielle Version fuer woody, daher die Symlinks.

> Ich brauchte einige Pakete aus der potato, habe aber kein Bock auf ein
> "Experimentalsystem" und mir kommt es so vor, als sei die woody eher
> ein solches Experimentierfeld.

Wenn du Packete aus potato brauchst musst du dafuer woody nicht
anfassen.

> Ist zu diesem Zweck meine source-list ok?
[...]
> deb ftp://ftp.de.debian.org/debian unstable main
> #deb ftp://ftp.de.debian.org/debian frozen main

Dann gehst du auf woody (unstable). Nimm lieber die auskommentierte
Zeile und kommentiere die Zeile drueber aus.

> Ich will, wenn endlich die potato rauskommt, ein komplettes Update
> machen und habe ueberhaupt keine Lust auf downgrade Stress.

Du musst nix downgraden. Aber du wirst sowieso eine Menge schon aus
potato installieren muessen um Packete daraus nutzen zu koennen. Die
meisten Packete in potato dependen naemlich auf Packete die es in
slink noch nicht gab, zumindest nicht in der entsprechenden Version.


Regards/Gruesse, Norbert

-- 
Norbert Tretkowski

Attachment: pgpF2ZmnSvp5Y.pgp
Description: PGP signature


Reply to: