[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#635491: marked as forwarded (texlive-latex-extra: ucshyper check for PDF mode buggy and not necessary anyway)

Your message dated Tue, 26 Jul 2011 13:00:23 +0200
with message-id <20110726110023.GA25752@capsaicin.mamane.lu>
has caused the   report #635491,
regarding texlive-latex-extra: ucshyper check for PDF mode buggy and not necessary anyway
to be marked as having been forwarded to the upstream software
author(s) tex-live@tug.org

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

635491: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=635491
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---

(Please keep 635491@bugs.debian.org in the CC list when replying).

ucshyper.sty tries (buggily) to disable itself when (la)tex is not run
in PDF output mode. But ucshyper works like a charm when producing a
DVI meant for post-processing with dvipdfm (and hyperref loaded with
hdvipdfm driver). I have only tested it with pdf(la)tex running in DVI
output mode, but I expect "plain" (la)tex would work just as well.

Patch attached. Assumes e-tex (uses \ifdefined). I assume this is OK.
I disabled the loading of hyperref, so that the user can choose hir
hyperref driver freely; instead a call to \hypersetup{unicode=true},
and hence a requirement that ucshyper be loaded *after* hyperref.

What would be your thoughts about upgrading the warnings (or maybe one
of them) to errors?

ucshyper.sty is in directory Master/texmf-dist/tex/latex/ucs

--- /usr/share/texmf-texlive/tex/latex/ucs/ucshyper.sty	2006-01-13 01:10:12.000000000 +0100
+++ ucshyper.sty	2011-07-26 12:47:40.000000000 +0200
@@ -7,19 +7,29 @@
 %% ucs.dtx  (with options: `ucshyper.sty')
 %% Copyright 2001 Dominique Unruh <dominique@unruh.de>
+%% Changed directly (not through ucs.dtx)in 2011 by
+%% Lionel Elie Mamane <lionel@mamane.lu>
+%% to allow use with .tex -> .dvi -> .pdf toolchain
+%% with latex and dvipdfm, using hyperref's hdvipdfm driver.
 %% This program is provided under the terms of the LaTeX Project Public
 %% License with some modifications.
 %% See the file LICENSE (http://www.unruh.de/DniQ/latex/unicode/content/LICENSE)
 %% for information.
     UCS: Unicode in Hyperref's PDF bookmarks]%
-  \PackageWarning{ucshyper}{ucshyper needs to be run with
-    pdflatex.\MessageBreak Disabling functionality}%
+\PackageWarning{ucshyper}{ucshyper needs to be run with
+    inputenc utf8x.\MessageBreak Disabling functionality}%
+ \hypersetup{unicode=true}%
+  \PackageWarning{ucshyper}{ucshyper needs to be loaded after
+      hyperref.\MessageBreak Disabling functionality}%
+    \expandafter\endinput%

--- End Message ---

Reply to: