[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: upload of tex-common ... ?

Norbert Preining <preining@logic.at> wrote:

> Hi Frank!
> On Do, 21 Feb 2008, Frank Küster wrote:
>> Reproducing was easy (just pbuilder login to etch, apt-get install
>> lmodern, edit sources list, apt-get update, apt-get install lmodern),
> I don't get it, I cannot reproduce this: I tried:
> - log into a clean etch
>   apt-get install lmodern
>   etch->sid
>   apt-get update
>   apt-get install lmodern
> 	-> did work

Hm, weird. First of all, I made one simple mistake: Since lmodern does
only depend on tex-common, not on tetex-bin, there's no updmap to
run when you do what I wrote. 

Now when I have a chroot with lmodern and tetex-bin from etch installed
and sid in the sources.list, I can upgrade lmodern without
problems. This is because neither tex-common nor tetex-bin are

After upgrading lmodern, tex-common can be upgraded, too, because it
doesn't run updmap; but after that "dpkg-reconfigure lmodern" fails in

The other way round, 

  log into a clean etch
  apt-get install lmodern tetex-bin
  apt-get update
  apt-get install tex-common
  apt-get install lmodern

also fails for the same reasons. (This is indeed a serious bug since
partial upgrades are supposed to work).

Now with a tex-common package that forces a dependency of
dh_installtex-using packages on sid's tex-common we get exactly the
second order of package installations (except that it's done in one dpkg
run). I've just tried that again.

Currently I'm building packages of tex-common-11~1 as in the repository,
and lmodern with it, and will hopefully report success this evening.

Regards, Frank

Frank Küster
Debian Developer (teTeX/TeXLive)

Reply to: