[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#386074: tetex-base: please update version of xkeyval package

severity 386074 wishlist
tags 386074 wontfix

mike castleman <m@mlcastle.net> wrote:

> Package: tetex-base
> Version: 3.0-20
> Severity: normal
> The package XeTeX [http://scripts.sil.org/xetex/] requires a newer 
> version of the xkeyval package than the one which is currently shipped 
> with Debain. The workaround is to forcefully remove the things that 
> Debian ships and use the one which XeTeX is shipping, but this is really 
> lame. 

No, the workaround is to install XeTeX (together with the xkeyval
version it is shipping) where every additional software should be
installed:  Either in /usr/local (so that xkeyval.sty gets into
/usr/local/share/texmf/tex/latex/xkeyval/xkeyval.sty) or in $HOME.  In
both cases, the updated xkeyval package will take precedence over the
one shipped with the Debian teTeX packages.

> It would be much preferred if Debian shipped with an up-to-date 
> version of xkeyval.

This won't happen, sorry.  We usually wait for a new upstream release of
teTeX (otherwise we'd have to start to maintain our own TeX
distribution, instead of just packaging teTeX).  However, teTeX has been
abandoned upstream.  It's successor, TeXLive, is also available in
testing; maybe its version of xkeyval is sufficient.

Regards, Frank
Frank Küster
Single Molecule Spectroscopy, Protein Folding @ Inst. f. Biochemie, Univ. Zürich
Debian Developer (teTeX/TeXLive)

Reply to: