[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#235401: tetex-bin: Fails to install in chroot

frank@kuesterei.ch (Frank Küster) schrieb:

> Daniel Schepler <schepler@math.berkeley.edu> wrote:
>> Based on some of the hints I saw, I was able to reproduce it in a
>> standard pbuilder chroot by first executing "apt-get --purge remove
>> apt-utils", then "apt-get install tetex-{bin|extra}".  I use pbuilder
>> chroots with the non-build-essential packages pruned from them,
>> including apt-utils, which I guess is why the buildd's and I were
>> seeing this bug but you couldn't reproduce it.
>> Let me know if this still isn't enough information to reproduce the
>> bug.
> Grr, still cannot reproduce. Perhaps our systems don't agree on what is
> a "standard pbuilder chroot". Could you give us a package list (dpkg -l
> | grep ^ii)?

I tried again, and now I can reproduce it. Don't know why, might be that
it makes a difference that I have set DEBIAN_FRONTEND to readline for my
pbuilder environments.

As Joaquin pointed out, it seems as if the following is responsible:

| The line 
|  uncomment_ldat "%! ngerman                dehyphn.tex"
| in the postinst file is taking away the comment character % from all the
| lines in the file language.dat that contain the word ngerman. This is
| wrong, one of the lines in language.dat is just a commentary that happens
| to have ngerman word in it.

However, I don't have any idea why this is the case. The uncomment_ldat
function looks like this: 

  newpattern=${pattern#%! }
  # we do the replacement globally, in case there are two lines for that pattern. 
  sed -e "s/$pattern/$newpattern/g" $LDAT > $TMP_LDAT
  chown --reference=$LDAT $TMP_LDAT
  chmod --reference=$LDAT $TMP_LDAT

So what it does should be

sed -e "s/%! ngerman                dehyphn.tex/ngerman                dehyphn.tex/g"

on the named files, and I cannot imagine

- how this can go wrong

- how this can be affected by the presense of apt-utils. Furthermore, I
  tried it as a standalone sed command, it worked fine, even without

So, as long as the battery of my laptop lasts, I'll investigate it.

> (Do you use a script for pbuilder to purge these packages?)

Still interessted in that.

Regards, Frank
Frank Küster, Biozentrum der Univ. Basel
Abt. Biophysikalische Chemie

Reply to: