[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

multiple maintainer support

[Bcc-ed to the list of current maintainers of multi-maintainer
 packages I'm aware of]


Both katie and dpkg-dev have finally been fixed to support multiple
maintainers properly.  To take advantage of this all you need is
dpkg-dev (>= 1.9.14)[1] and to add an 'Uploaders:' field to the first
paragraph of debian/control. e.g.

| Source: debian-policy
| Section: doc
| Priority: optional
| Maintainer: Debian Policy List <debian-policy@lists.debian.org>
| Uploaders: Julian Gilbey <jdg@debian.org>, Manoj Srivastava <srivasta@debian.org>
| Standards-Version: ${debian-policy:Version}
| Build-Depends-Indep: links, debiandoc-sgml (>= 1.1.47), sp, liburi-perl, libpaperg, tetex-bin, tetex-extra, latex2html, libi18n-langtags-perl, groff, bsd
| mainutils, pstoedit, tidy, jade, docbook-xml

Then any uploads of debian-policy by Julian or Manoj will have their
bugs closed as opposed to incorrectly tagged as NMU fixed.  HTH, any
problems, give me a shout.

[Random notes:
  (1) Like other katie NMU checks, the comparison is done on a
      name-only basis, not the full string (i.e. email address is

  (2) Only people doing sourceful uploads should be list in the
      'Uploaders' field, as people non-sourceful uploads don't
      close/tag as fixed bugs.]


[1] It won't break with older versions, it will just be ignored by
    dpkg-source and not added to the .dsc.

Reply to: