[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-get dist-upgrade broken: udev

On Mon, 2005-09-19 at 14:08 -0400, Brandon Kuczenski wrote:
> A transcript:
> # apt-get dist-upgrade
> Reading Package Lists...
> Building Dependency Tree...
> You might want to run `apt-get -f install' to correct these.
> The following packages have unmet dependencies:
>    hal: Depends: udev (>= 0.063) but 0.056-3 is installed
> # apt-get -f install
> Reading Package Lists...
> Building Dependency Tree...
> Correcting dependencies... Done
> The following extra packages will be installed:
>    udev
> The following packages will be upgraded:
>    udev
> 1 upgraded, 0 newly installed, 0 to remove and 26 not upgraded.
> 410 not fully installed or removed.
> Need to get 0B/310kB of archives.
> After unpacking 270kB of additional disk space will be used.
> Do you want to continue? [Y/n]
> (Reading database ... 135159 files and directories currently
> Preparing to replace udev 0.056-3
(using .../archives/udev_0.068-2_i386.deb) ...
> udev requires a kernel >= 2.6.12, upgrade aborted.
> #

I was getting this same problem too yesterday.
I worked round it using apt-get only by doing something like (IIRC)
  apt-get remove udev hal gnome-volume-manager magicdev+
(the latter needed to provide a gnome dependency with a suitable
alternative) then apt-get install the linux-image-2.6.12 (I was on
2.6.8), which worked fine with udev off the scene, then uninstall
magicdev while reinstalling udev hal and gnome-volume-manager.  

Although if I'd though of it Peter C Norton's suggestion of simply dpkg
-i installing the linux-image-2.6.12 would have been easier.

I think the root of these problems is the udev install aborting when it
doesn't find a kernel 2.6.12 running, when in fact it seems to be
perfectly capable of installing but then simply not activating when
kernels <2.6.12 are not running.


Reply to: