[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#220163: marked as done (installation-reports: netboot install attempt via PXE)

Your message dated Wed, 12 Nov 2003 19:31:13 -0500 (EST)
with message-id <20031113003113.583FC1C93D@laptop.nahmias.net>
and subject line All problems resolved
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 11 Nov 2003 06:44:00 +0000
>From joe@nahmias.net Tue Nov 11 00:43:58 2003
Return-path: <joe@nahmias.net>
Received: from firecrest.mail.pas.earthlink.net [] 
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1AJSFq-0003DN-00; Tue, 11 Nov 2003 00:43:58 -0600
Received: from user-0ccerdr.cable.mindspring.com ([] helo=laptop.nahmias.net)
	by firecrest.mail.pas.earthlink.net with asmtp (Exim 3.33 #1)
	id 1AJSFq-0006zG-00
	for submit@bugs.debian.org; Mon, 10 Nov 2003 22:43:58 -0800
Received: by laptop.nahmias.net (Postfix, from userid 1000)
	id 733DA1C938; Tue, 11 Nov 2003 01:43:56 -0500 (EST)
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Joe Nahmias <joe@nahmias.net>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: installation-reports: netboot install attempt via PXE
X-Mailer: reportbug 2.36
Date: Tue, 11 Nov 2003 01:43:56 -0500
Message-Id: <[🔎] 20031111064356.733DA1C938@laptop.nahmias.net>
X-ELNK-Trace: 191428ea1bb0d49f94e8f37458d87bc5239a348a220c26090eb9cf6dabe64a0702fba3f6c0e52b6093caf27dac41a8fd350badd9bab72f9c350badd9bab72f9c
Delivered-To: submit@bugs.debian.org
X-Spam-Status: No, hits=-4.0 required=4.0
X-Spam-Checker-Version: SpamAssassin 2.53-bugs.debian.org_2003_11_9 (

Package: installation-reports
Version: netboot daily image from 2003-11-10
Severity: normal
Tags: d-i


Debian-installer-version: daily netboot image from <http://people.debian.org/~sjogren/d-i/images/2003-11-10/>
uname -a: Linux (none) 2.4.22-1-386 #9 Sat Oct 4 14:30:39 EST 2003 i686 unknown
Date: Tue Nov 11 01:03:47 EST 2003
Method: netboot via PXE

Machine: Dell Inspiron 1100 laptop
Processor: Intel Celeron 2GHz
Memory: 256MB
Root Device: N/A
Root Size/partition table: N/A
Output of lspci: /bin/sh: lspci: not found

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [ ]
Detect CD:              [ ]
Load installer modules: [ ]
Detect hard drives:     [ ]
Partition hard drives:  [ ]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Alright, here are the highlights of how this install went:

0) OK, after much struggling (and dealing with my nemesis error message
'VFS: Cannot open root device "" or 3a:04') I managed to get the d-i
netboot image to work via PXE.  For posterity (and the installation
guide) the magic kernel options I needed to make this work are
"ramdisk_size=8192 root=/dev/ram0".  If anyone would like assistance
setting up a PXE testbed or copies of various configs I use please don't
hesitate to ask.

1) Install boots into the main menu.  Interface looks alot snazzier than
the old text interface, however the line-drawing characters are all
messed up on my terminal (corners are displayed as '>', &c.)  Known bug?

2) Picking "Choose language" doesn't get very far.  This is what I can
piece together from syslog:

DEBUG: Menu item 'languagechooser' selected
DEBUG: configure languagechooser, status: 4
WARNING **: Configuring 'languagechooser' failed with error code 1
WARNING **: Menu item 'languagechooser' failed.

Any ideas?  Known unfiled bug?  File a new bug against languagechooser?

3) After doing 'Select a Keyboard Layout', I chose 'Detect network
hardware'.  This generated the following two (fatal looking) errors:

  a. An error occured while running 'modprobe -v floppy false`.
  b. An error occured while running 'modprobe -v ide-cd false`.

Since this is a netboot install, these errors should not be fatal.

4) When finally presented with a list of ethernet drivers to pick from,
the requisite driver for this laptop -- b44 -- is missing.  I tried
switching to vc2 and doing 'modprobe -v b44', but this fails since the
module doesn't exist on the image.  How do we get it added?

Well, that's as far as I got.  Hope this helps!


PS - This particular laptop doesn't have a serial port, so all
output/error messages are hand-typed and subject to typos, &c.

-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux laptop 2.4.22-1-686 #6 Sat Oct 4 14:09:08 EST 2003 i686
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8

Received: (at 220163-done) by bugs.debian.org; 13 Nov 2003 00:31:15 +0000
>From joe@nahmias.net Wed Nov 12 18:31:15 2003
Return-path: <joe@nahmias.net>
Received: from stork.mail.pas.earthlink.net [] 
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1AK5OF-00053N-00; Wed, 12 Nov 2003 18:31:15 -0600
Received: from user-0ccerdr.cable.mindspring.com ([] helo=laptop.nahmias.net)
	by stork.mail.pas.earthlink.net with asmtp (Exim 3.33 #1)
	id 1AK5OE-0003Zo-00; Wed, 12 Nov 2003 16:31:14 -0800
Received: by laptop.nahmias.net (Postfix, from userid 1000)
	id 583FC1C93D; Wed, 12 Nov 2003 19:31:13 -0500 (EST)
Subject: All problems resolved
To: 220163-done@bugs.debian.org
Date: Wed, 12 Nov 2003 19:31:13 -0500 (EST)
Cc: debian-boot@lists.debian.org
X-message-flag: Formating hard disk. please wait...   10%...   20%...
X-Mailer: ELM [version 2.4ME+ PL100 (25)]
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
Content-Type: text/plain; charset=UTF-8
Message-Id: <20031113003113.583FC1C93D@laptop.nahmias.net>
From: joe@nahmias.net (Joe Nahmias)
X-ELNK-Trace: 191428ea1bb0d49f94e8f37458d87bc5239a348a220c2609e494b4134d5fac7b03a853353ecd199a387f7b89c61deb1d350badd9bab72f9c350badd9bab72f9c
Delivered-To: 220163-done@bugs.debian.org
X-Spam-Status: No, hits=1.0 required=4.0
X-Spam-Level: *
X-Spam-Checker-Version: SpamAssassin 2.53-bugs.debian.org_2003_11_9 (


It seems all the problems I reported in this bugreport have been fixed
in today's (2003-11-12) netboot image.  Thanks to everyone who helped!


PS - Expect a new install report sometime soon with all the new ones :)

Reply to: