[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#919961: sope: FTBFS on sh4: PrintfFormatScanner.m:43:9: error: wrong type argument to unary exclamation mark

On 1/21/19 10:50 PM, Yavor Doganov wrote:
>> I suggest upstreaming this patch if possible.
> Right, forgot to mention it.  The patch may need some tweaking in the
> distant future because va_list is a pointer on SH-5, if I'm not
> mistaken.  However, support for SH-5 has been removed in GCC 7 and
> seems unlikely to be reintroduced any time soon.

Don't worry about SH-5, this architecture never existed in hardware,
so it's not surprising it was eventually removed from gcc.

>>> | dh_shlibdeps: file -e apptype -e ascii -e encoding -e cdf -e compress -e tar debian/libsope1/usr/lib/libNGMime.so.4.9.3 returned exit code 1
>> Your version of qemu is most likely outdated, this particular issue
>> was fixed by this commit [1].
> Yes, I'm using the stock stretch package (1:2.8+dfsg-6).
>> When using qemu-user, I always recommend building qemu from git.
> Thanks; I didn't know this.  I tried with qemu from git but it still
> fails with the same error.  Perhaps I'm not building it properly, I'll
> take a closer look when I find the time.

Make sure you overwrite the binary in both /usr/bin and the chroot's
usr/bin and restart binfmt-support if necessary. Also, the binary
has to be called "qemu-sh4-static" in Debian while qemu upstream
calls it "qemu-sh4".


 .''`.  John Paul Adrian Glaubitz
: :' :  Debian Developer - glaubitz@debian.org
`. `'   Freie Universitaet Berlin - glaubitz@physik.fu-berlin.de
  `-    GPG: 62FF 8A75 84E0 2956 9546  0006 7426 3B37 F5B5 F913

Reply to: