[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#570587: scilab: Please support Renesas SH(sh4)

Source: scilab
Version: 5.2.1-1
Severity: important
Tags: patch
User: debian-sh4@superh.org
Usertags: sh4
X-Debbugs-CC: debian-superh@lists.debian.org


I am now trying to run Debian on Renesas SH(sh4) CPU.

scilab FTBFS on SH4.
Because  scilab does not support Renesas SH.
checking java API version... 1.5
Using the following JNI include flags
checking if jni.h can be included... yes
Looking for JNI libs with sh4a as machine hardware name
Looking for /usr/lib/jvm/java-6-openjdk/jre/lib/sh4a/libjava.so
Looking for /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/libjava.so
Looking for /usr/lib/jvm/java-6-openjdk/jre/lib/i386/client/libjvm.so
Looking for /usr/lib/jvm/java-6-openjdk/jre/bin/classic/libjvm.so
Looking for /usr/lib/jvm/java-6-openjdk/../Libraries/libjava.jnilib
Looking for /usr/lib/jvm/java-6-openjdk/lib/jvm.lib
Looking for /usr/lib/jvm/java-6-openjdk/jre/lib/mipsel/libjava.so
configure: error: Could not detect the location of the Java
            shared library. You will need to update java.m4
            to add support for this JVM configuration.
make: *** [debian/stamp-autotools-configure] Error 1

I made patch to support SH. I applied this patch and built a package,
but was able to build normally.
Could you apply this patch?

Best regards,

Nobuhiro Iwamatsu
   iwamatsu at {nigauri.org / debian.org}
   GPG ID: 40AD1FA6

Attachment: scilab-sh4javadetection.diff
Description: application/octetstream

Reply to: