[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#541775: inetutils: FTBFS: build error in configure

Package: inetutils
Version: 2:1.6-1
Severity: serious


I am now trying to run Debian on Renesas SH CPU(sh4).
I built inetutils. But this became the build error. 
And I tried even i386, but become the same error.

The build failed with the following error: 
checking for unistd.h... (cached) yes
checking for vis.h... no
checking return type of signal handlers... void
checking for socklen_t... yes
checking for struct osockaddr... yes
checking for struct if_nameindex... yes
checking for sig_t... yes
checking for sigset_t... yes
checking for sig_atomic_t... yes
checking for sa_family_t... yes
checking for cc_t... yes
checking for long long... yes
checking for long double... yes
checking for struct sockaddr_in.sin_len... no
./configure: line 21152: syntax error near unexpected token `}'
./configure: line 21152: `$as_echo_n "checking for struct utmp.ut_pid...
" >&6; }'
make[1]: *** [config.status] Error 2
make[1]: Leaving directory `/tmp/buildd/inetutils-1.6'
make: *** [setup-source] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

Please fix this problem.

Best regards,

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)

Kernel: Linux 2.6.30-1-686-bigmem (SMP w/2 CPU cores)
Locale: LANG=ja_JP.UTF-8, LC_CTYPE=ja_JP.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Reply to: