[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#460136: please include armel in debian/control architecture list to guarantee selinux support

Package: openssh
Version: 1:4.7p1-1
Severity: wishlist
User: debian-arm@lists.debian.org
Usertags: eabi

debian/control says:
Build-Depends: libselinux1-dev [alpha amd64 arm armeb hppa i386 ia64
lpia m68k mips mipsel powerpc ppc64 s390 sparc], libgnomeui-dev (>=
2.0.0) | libgnome-dev

to which "armel" should be added.

In practice, both of the alternatives libgnome-dev and libgnomeui-dev
are available, of which -ui-dev also brings in libselinux1-dev and
-dev does not.

At present it has built on armel with libgnomeui and thus selinux was
present by chance;
With libgnome-dev installed and no libselinux1-dev, "configure" fails
for lack of selinux headers.

Does the order in which alternatives are listed imply an order of
preference when several of them are present?

Reply to: