[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#250311: ssh: pubkey auth fails between 3.8.1p1-3 and 3.4(woody)

Package: ssh
Version: 1:3.8.1p1-3
Severity: important

I cannot connect to an ssh daemon running woody's current version
(1:3.4p1-1.woody.3) from the sarge/sid current version.  I have no
problems connecting to a client/server pair both running 3.8.1p1-3.
Default configuration files on all tests.

An example of where this hurts is when trying to get CVS repositories
from savannah.gnu.org.  Since they do not accept password authentication
and require publickey authentication, I cannot get read/write access to
the repositories.

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (990, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.6.4-k7
Locale: LANG=C, LC_CTYPE=en_US.ISO-8859-1 (ignored: LC_ALL set to C)

Versions of packages ssh depends on:
ii  adduser                     3.53         Add and remove users and groups
ii  debconf                     1.4.25       Debian configuration management sy
ii  dpkg                        1.10.21      Package maintenance system for Deb
ii  libc6                       2.3.2.ds1-12 GNU C Library: Shared libraries an
ii  libpam-modules              0.76-21      Pluggable Authentication Modules f
ii  libpam-runtime              0.76-21      Runtime support for the PAM librar
ii  libpam0g                    0.76-21      Pluggable Authentication Modules l
ii  libssl0.9.7                 0.9.7d-1     SSL shared libraries
ii  libwrap0                    7.6.dbs-3    Wietse Venema's TCP wrappers libra
ii  zlib1g                      1:1.2.1-5    compression library - runtime

-- debconf information:
  ssh/privsep_ask: true
* ssh/user_environment_tell: 
* ssh/forward_warning: 
  ssh/new_config: true
* ssh/use_old_init_script: true
* ssh/SUID_client: true
* ssh/privsep_tell: 
* ssh/protocol2_only: true
* ssh/run_sshd: true

Reply to: