[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

problem booting Debian on X1

I've got a well-established Sun X1 that's been running Debian6 for years. it's got two disks raid1 via mdadm.

Recently, we rebooted the server (was healthy afaict) and it won't come back. When it tries to boot, it prints "SI" (where it would normally say SILO and continue booting) and then just gets stuck.

I've tried booting directly to disk2:3 and it does the same thing. I've tried swapping the disks around and haven't gotten any further. I moved the disks to a different chassis, changed memory, changed cables, all yields the same.

Any ideas how I can get this server to boot? I'd like to try to reinstall SILO, but I am having trouble finding how to do that. When I boot to a Debian6 sparc cd and go into rescue mode, after it loads modules from the cdrom the terminal just hangs (or sits there longer than I've waited for it - 30-40 min).

I also tried reinstalling SILO from the expert menu of the installer, but i can't install SILO without installing the base system (it's a prereq).

The expert mode shell doesnt see either disk; nothing is mounted on /target.


Jeremy Kister

Reply to: