[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unable to boot Debian Squeeze on Sun Blade 1500 Silver

> Sorry for the late reply. I forgot what the error message was and had
> to wait on someone to message it to me. (This machine is at my
> ex-college).
> The hard disk has Linux (Debian) only on it.
> Yes, the SILO bootloader was installed correctly; at least it did not
> show any error messages.
> When I start the machine, I get the OpenBoot prompt. The error shown
> is as such:
> "Boot device: disk File and args:
> The file just loaded does not appear to be executable"

> Even if I manually type the boot command, it shows the same error.
> I do not know if it is fit into slot 0. I will have to check. (I will
> check it when I go there this Saturday).
> Yes, I can boot the Debian Squeeze CD by typing "boot cdrom" from the
> OpenBoot prompt. Then, when I enter rescue mode, I can execute a root
> shell on the hard disk which has the Squeeze '/' filesystem. From
> there, I can see that everything seems to be have been installed
> correctly.
> One more thing I forgot to mention is that I used the netinst CD. It
> needed a non-free driver for the ethernet card. So, I downloaded the
> non-free kernel drivers' package, put it on a flash drive and tried to
> install it during the installation process. But, for some reason, it
> would not mount the flash drive. If this netinst (without internet
> access) may have been the problem, I will download the installer DVD
> and try the install again.
> Hope this helps to pin-point the problem.

This all looks well. If you execute a root shell, what does # fdisk -l
look like? I found a topic by Google, linking here ...


Thanks! I will definitely try this. I had created a swap partition at the end and then, I had used the remaining space to create a '/' partition from the begining. But I will try the boot disk?:c parameter. It again comes down to the question you had asked me earlier: Whether the disk is in slot 0 or not...

I do not know what goes on yet, but the non-free part is probably a
firmware needed & thats okay. Are you sure its for the Ethernet driver.
Or does it drive the SCSI controller?

During the installation, the debian-installer showed me the name of the missing firmware file. I googled it. It was for the ethernet card: Broadcom BCM5701A0 firmware (tigon/tg3.bin).

Do a # dmesg | grep firmware in root shell to be sure. And take a look
the firmware is in /lib/firmware as well.

If the disk fits in 1, instead of 0 you can try boot with $ boot disk1

Yes, it could be the problem. I will try this and get back to the list.

Thanks and Best Regards,
Rigved Rakshit

Reply to: