[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unable to boot Debian Squeeze on Sun Blade 1500 Silver

> I have successfully installed Debian Squeeze on a Sun Blade 1500
> Silver machine. But when I try to boot it from OpenBoot using the
> "boot" command, it does not boot. I have tried to run the recovery
> mode of the Debian Squeeze CD too, but to avail.
> Can anyone help me regarding this? I do not have any prior experience
> with UltraSPARC machines.

Are you running Linux only? Did installing the SILO bootloader went
well? Does that show up? Any error? Is the hard-drive fit in slot 0? Are
you able to boot the Debian Squeeze CD and go into the installed chroot?

Sorry for the late reply. I forgot what the error message was and had to wait on someone to message it to me. (This machine is at my ex-college).

The hard disk has Linux (Debian) only on it.

Yes, the SILO bootloader was installed correctly; at least it did not show any error messages.

When I start the machine, I get the OpenBoot prompt. The error shown is as such:

"Boot device: disk File and args:

The file just loaded does not appear to be executable"

Even if I manually type the boot command, it shows the same error.

I do not know if it is fit into slot 0. I will have to check. (I will check it when I go there this Saturday).

Yes, I can boot the Debian Squeeze CD by typing "boot cdrom" from the OpenBoot prompt. Then, when I enter rescue mode, I can execute a root shell on the hard disk which has the Squeeze '/' filesystem. From there, I can see that everything seems to be have been installed correctly.

One more thing I forgot to mention is that I used the netinst CD. It needed a non-free driver for the ethernet card. So, I downloaded the non-free kernel drivers' package, put it on a flash drive and tried to install it during the installation process. But, for some reason, it would not mount the flash drive. If this netinst (without internet access) may have been the problem, I will download the installer DVD and try the install again.

Hope this helps to pin-point the problem.

Thanks and Best Regards,
Rigved Rakshit

Reply to: