[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re (3): vsftpd server problem,

On Friday, 13 January, 2012 11:45 PM, peasthope@shaw.ca wrote:
Hi jaomadn,

From:	jaomadn<jaomadn@gmail.com>
Date:	Fri, 13 Jan 2012 19:19:58 +0800
What do you mean "telnet host port give?".
To varying extents depending upon the protocol, telnet can be
used interactively for troubleshooting.  See man telnet.  For
example test connectivity to your SMTP server.
   telnet your.smtp.server.com 25

This is what I get from a working vsftpd at joule.

peter@dalton:~$ telnet joule 21
Connected to joule.invalid.
Escape character is '^]'.
220 (vsFTPd 2.3.2)

<Ctrl>+] escapes.  Do you get the analogue of that for your context?

Does traceroute get through?

i dont really know where the problem lies..
Do you have /etc/hosts.allow or /etc/hosts.deny?  What do
they contain?

With ping you've proven that ICMP works.  Continue to  work
through the layers until the blockage is identified.

Regards,            ... Peter E.

Hi i dont have the /etc/host.(deny|allow) file
traceroute is working fine only 3 hops
nmap detect open ftp ports

Here are the msg when try to ftp connection

421 service not available, remote server has closed connection

But nmap detect and netstat know it listening in ports 21.

I dont understand as vsftpd default configuration when fresh installed allow anonymous login but this doesn't.

I thought if this is a update problem since i fresh installed it i never connect or update it the internet cause im inside of a local network but i believe installation of vsftpd is out of the box right.

There an odd msgs if i stop and start vsftpd in the /etc/init.d/vsftpd stop|start command it throw a error msg
No /usr/sbin/vsftpd found running; none killed
and procedd start and stop it. but if i check it in ps -ef theres an vsftpd process startes at mother 1 and spawn almost 5 process. I already try to kill it all and start the process again but still i dont have connection established.. this start stop problem show also in the proftp-basic when i tried it and still no connection.

Reply to: