[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

install debian on sparc; error at reboot (from freshly written disc)

Hello there,

I have a few SunBlade 2500 machines and i am trying to install debian on them,
more precisely i burned the debian-506-sparc-netinst.iso on a cd and after some
trouble i managed to boot from it and apparently finished the installation
successfully. However, at normal boot from the freshly written disk, i got the
following error:
   ERROR: /packages/zfs-file-system: Last Trap: Fast Data Access MMu Miss
I have no clue how to handle this, but i am adding below some more info around
some suspicions i have.


-- more details --

At the open-boot prompt i tested for disks:

  {1} ok probe-scsi
  Target 0
    Unit 0 Disk FUJITSU MAW3147NCSUN146G1703  #xyz Blocks, 140009 MB
  Target 1
    Unit 0 Disk FUJITSU MAW3147NCSUN146G1703  #xyz Blocks, 140009 MB

and when i got to repartitioning the disks with the debian installer, the
screen displayed something like:

  scsi1 (0,0,0) (sda) - 146.8 GB FUJITSU MAW3147...
  scsi1 (0,1,0) (sdb) - 146.8 GB FUJITSU MAW3147...

However, i was only able to partition the second listed disk, sdb, not sda,
so i created the simplest partition possible:

  scsi1 (0,1,0) (sdb) - 146.8 GB FUJITSU MAW3147...
  >     #1     131.3 GB    /  ext3
  >     #2       7.4 GB       swap

I also tried formatting the / partition to ext2, as i found somewhere that
SILO is able to boot from an ext2 fs (same error).

Then, i booted one more time from the CD on the system installed as above
(ext2 fs), in rescue-mode, into sdb1 as the / filesystem, and ran a shell
in /dev/sdb1. I looked at the two disks:

-- the one i could not format/partition from th installer:
> fdisk -l /dev/sda
Disk /dev/sda (sun disk label): 24 heads, 848 sectors, 17846 cylinders
Units  = cylinders of 20352 8 512 bytes

device ...
/dev/sda3	0	14089 	many	5	whole disk

-- the one i did format/partition:
> fdisk -l /dev/sdb
detected sun disklabel with wrong version [0x00000000].
detected sun disklabel with wrong sanity [0x00000000].
detected sun disklabel with wrong num_partitions [0].
Warning: wrong values need to be fixed up and will be corrected by w(rite)

Disk /dev/sdb (sun disk label): 255 heads, 63 sectors, 17848 cylinders
Units = cylinders of 16065 * 512 bytes

device	flag	start	end	blocks	id	system
/dev/sdb1	0	17021	many	1	boot
/dev/sdb2 	17021	17848	few	82	linux swap
/dev/sdb3	0	17848	all	5	whole disk

- i tried to write the partition table (without changing anything,
hoping that a 'w' command within fdisk will fix these things as stated
in the display above, but since i was using the partition, it said the
changes will be used after reboot, but since i have to boot again from
the cd, nothing changes)

Reply to: