[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Sun Blade 100 -- Installer can't see disks

Hi. I don't know if this is related to Nataraj Basappa's problem above
or not. It sounds like it might be, but perhaps a worse incarnation.

I am trying to install 5.0.2 on a Blade 100. I first tried a
netinstall CD. Openboot refused to see the disc, producing the 'bad
disk label' error. I then setup the rarp/tftp netinstall option using
the image here:


The image boots fine, and the installer progresses to disk detection,
at which point it says that it can not detect the disk, aska me to
select a driver.

Switching to the shell, I see the ALI IDE controller in lspci. I also
see in lsmod that alim15x3 is loaded. When I look in /proc/ide, I see
ide0 and ide1 directories, but no hda, hdb, etc.

I'd like to try using the ide=nodma option, but I don't get a SILO
prompt when using the tftp option. Is there a way to pass kernel
options to the tftp image?

Another thing that may be significant, is that I got the machine with
an ancient version of Red Hat on it (with a 2.4 kernel). Before I
tried to install debian, it would boot. But now when I do 'boot disk'
from OBP, it produces the "bad magic number in disk label" error. I
did remove the disk at one point, but I've checked several times to
make sure everything is seated properly.

Thanks for any help anybody may have on this. Please let me know if
any more information might be useful.

Jordan Bettis

Reply to: