[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sun Leo (ZX)

Apologies for the delay and lousy threading- I lost the connection to the ML.

On Fri, 18 Apr 2008 14:40:13 +0200 Tom "spot" Callaway wrote:

>>> I think I could usefully put some printk()s in leo.c, but I need to
>>> sort out the disc before I have any chance of compiling that.
>>I'm back on this and I've been having fun with printk()s. What I can
>>see is:
>>[MarkMLl] Entered leo_init()
>>[MarkMLl] In leo_init(), matched option
>>[MarkMLl] Entered of_register_driver()
>>[MarkMLl] driver_register() -> 0
>>[MarkMLl] of_register_driver() -> 0
>>Console: switching to mono PROM 80x34
>>rtc_init: no PC rtc found
>>I think that the return from driver_register() hence
>>of_register_driver() indicates success so leo_init() is OK, however I
>>don't see control being transferred into leo_probe().

>> What is the significance of the match check? I presume this is a
>> device
>> name but what is it tested against?
>If memory serves, its checking for that value in the openpromfs.

After comparing various drivers I've patched leo.c to match against "SUNW,leofb" rather than just "leofb" and the driver is now loading. Unfortunately it crashes the machine almost immediately- I see "Booting Linux..." followed by a clear screen then it's in a totally unresponsive state. It's worth noting that it's a /fast/ clear screen, not the five seconds it took when the kernel had fallen back to the PROM for output, so I know it's the Leo driver doing it... progress :-)

That leaves me in a position where I can't see printk() output. I considered using prom_printf() which is how I got Linux running on my SS1000E, however I note that that's deprecated- how do I use the -p option that's supposed to flush printk() output to the console promptly?

I've tried various combinations of video=offb:on etc. but something that I haven't tracked down is overriding that- I suspect it might be SILO doing some well-meaning sanity checks. I'd add that in all of the above I've tried using a serial console to no advantage.

I suspect that what I need to do is put kernel 2.4 on the system and check whether it works, then compare a 2.6 driver with a 2.4 to get a list of required changes- are these documented anywhere?

I'll continue tinkering when I can find time but any guidance would be appreciated.

Mark Morgan Lloyd
markMLl .AT. telemetry.co .DOT. uk

[Opinions above are the author's, not those of his employers or colleagues]

Reply to: