[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


I have a Sun Ultra 60 with a pair of 73 GB Seagate drives and I want to set up RAID1 mirroring.

My layout is

sda1    100MB    /boot
sda2    71GB      /
sda4    3GB       swap

I've googled this to death and I'm almost blind.

I found this http://www200.pair.com/mecham/raid/raid-index.html which gets me close except that mdcfg won't let me set the /boot partitions into "physical volume for RAID" on either drive (not sure why, perhaps bootblock) during initial setup.

And this http://www.howtoforge.com/software-raid1-grub-boot-debian-etch is what I have been following to the letter. I've completed all of it up to page 2 where it says "Now up to the GRUB boot loader. Open /boot/grub/menu.lst and add fallback 1 right after default 0:"

I am stuck on both of these for the same reason; NO GRUB! It's SILO of course! I am lost trying to get this configured. I've tried adding some of the suggested line items from other LILO topics related to RAID1 on Etch but when I run SILO on the machine it typically tells me that the file has a problem like when I add things like the "prompt" command.

I have the md0, md1 and md2 RAID devices created with the first disk as missing and the 2nd drive sdb1 (/boot), sdb2 (/) and sdb4 (swap) added to the array and mounted. I don't know if I'm booting from the /boot partition or the mbr (since sector 0 appears to be the start of the /boot partition from fdisk -l output)

I'm stuck.

Any takers?


Reply to: