[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Sun Blade 2000

I encountered some problems installing Debian on a Sun Blade 2000 and I
wrote them down, maybe someone could find them useful.

Now my Blade 2000 is running Debian sid with X working properly and
without the annoying fan noise. :)

The daily netinst CD fails to boot with 'Invalid instruction'. It seems
to be a known problem, so I installed via netboot (rarpd + tftpd-hpa).

There's another known problem with the atyfb driver [1]: it hangs the
kernel at boot time if the kernel itself is built with certain versions
of gcc.

That's what I told to openboot to start the installer:
boot net video=atyfb:off 

The current version of debian-installer works *a lot* better than the
sarge version: keyboard and debconf output are not screwed up, so it's
now possible to continue the installation from the blade itself rather
than via ssh (as I used to do with the sarge installer).

On the other hand, with the current kernel image the hard disk is not
recognized because the QLA2200 64-bit Fibre Channel Adapter doesn't work
without the non-free firmware, while the sarge installer (using a 2.6.8
kernel) was able to see the adapter via the qlogicfc module without any
external firmware.

I've tried using reiserfs for the root partition, but silo doesn't work
with filesystems which are not ext3/ext2/ufs; it would be very cool IMHO
to warn the user about that if he tries to use something different from
ext3/ext2. I know that one should RTFM before installing, but going
through the whole installation just to realize that the machine won't
boot, err, sucks.

X and noise
The machine has two video cards: 
 - ATI Technologies Inc Rage XL not recognized by X.org (Debian bug
 - Sun FFB2 Vertical Creator 3D not working without its non-free
   firmware: #287249

X works correctly using afbinit to load afb.ucode (the firmware).
afbinit itself is a bit buggy, I had to modify the init script to make
it work (#411415).

The machine is *very* noisy, while under Solaris it's not.
I've tried the kernel patch by Joerg Friedrich [2] and it seems to fix
this problem smoothly.

I've applied it (linux-source-2.6.18 2.6.18.dfsg.1-10), but I also
needed to apply the patch by Jurij Smakov (#411135) to get rid of the
following error loading the bbc module:
bbc: Unknown symbol execve 

The only evident kernel problem (at least from dmesg) is:

Kernel unaligned access at TPC[101720c8] ether1394_reset_priv+0x2c/0xb8[eth1394]
(using linux-image-2.6.18-4-sparc64-smp 2.6.18.dfsg.1-10)

But it's probably fixed in recent kernels [3], or it's at least known


[1] http://article.gmane.org/gmane.linux.ports.sparc/7116
[2] http://lists.debian.org/debian-sparc/2007/02/msg00045.html
[3] http://lkml.org/lkml/2006/10/10/141

Attachment: signature.asc
Description: Digital signature

Reply to: