[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Please test the new kernel (2.6.18.dfsg.1-9)

On Wed, 31 Jan 2007 23:16:04 PST, Jurij Smakov writes:
>> I installed this on an up-to-date Etch U1 (sun4u), and it boots until it'd 
>>  like to mount the root-filesystem. Which fails, and if I'm not 
>>  mistaken, because it hasn't loaded any SCSI-drivers (esp in the case 
>>  of my U1). So I threw in yaird, which actually loaded scsi_mod, but 
>>  still no esp, so I had to explicitly set "MODULE esp" in yairds config
>>  so that it would actually load esp and could go on booting.

>Thanks for the report. This problem has been reported for yaird as bug

Erm, I didn't have yaird installed at first, mkinitramfs-kpkg didn't 
 even include SCSI at all. Which's why I then tried yaird.

>#341522 for over a year now without any reaction from maintainer, so 
>the chances that it's going to be solved in time for etch are pretty 
>slim. If you have a chance, please try initramfs-tools, which is an 
>alternative (and currently, the default) initrd generator. Simply 
>installing initramfs-tools, removing yaird and then running 
>'dpkg-reconfigure linux-image-2.6.18-4-sparc64' should regenerate the 
>initrd using it.

I prefer to toggle via kernel-img.conf, no need to remove yaird for
 that ;)

root@pham:/tmp/a# dpkg-reconfigure linux-image-2.6.18-4-sparc64
Running depmod.
Finding valid ramdisk creators.
Using mkinitramfs-kpkg to build the ramdisk.
Other valid candidates: mkinitramfs-kpkg mkinitrd.yaird

root@pham:/tmp/a# gunzip </boot/initrd.img-2.6.18-4-sparc64 | cpio -i
25147 blocks
root@pham:/tmp/a# find . -name esp\*

No esp.ko :(

-- "Any sufficiently advanced political correctness
-- is indistinguishable from irony."  - Erik Naggum

Attachment: pgpmcwVvp4Wuv.pgp
Description: PGP signature

Reply to: