[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

SMP on Sun4m / Sun4c on Etch


Last weekend I installed Debian Etch on a Sun Sparcstation 10 with 2x 
Texas Instruments, Inc. - SuperSparc-(II) (50MHz) CPUs.
I found no SMP-Kernel for 32bit, the installation manual suggests to 
compile one myself.
I tried this (following 
http://d-i.alioth.debian.org/manual/en.sparc/ch08s05.html), but it 
failed now twice during compilation with a Segmentation fault (Output 
can be found at the end of this mail).
I found an old statement from Rob Radez saying that Linux 2.6 and SMP on 
sparc32 are not working at all. Is this still true, or is the problem 
located between keyboard and chair?

The manual also states that sun4c is supported on Etch (it was at least 
not on 
sarge). I just tried to netboot the installer on my Sparcstation 2, it 
starts to load, and after some time (I think when the download is 
finished), the screen turns off. I don't think this is a hardware 
problem, the system was running Debian Woody in the past.

More general asked, am I wrong, or is the manual wrong/outdated?



peter@ss10:~$ gcc --version
gcc (GCC) 4.1.2 20061028 (prerelease) (Debian 4.1.1-19)

output from "fakeroot make-kpkg --initrd --revision=custom.1.0 
  CC      crypto/digest.o
  CC      crypto/compress.o
crypto/compress.c: In function âcrypto_init_compress_flagsâ:
crypto/compress.c:42: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
For Debian GNU/Linux specific bug reporting instructions,
see <URL:file:///usr/share/doc/gcc-4.1/README.Bugs>.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[2]: *** [crypto/compress.o] Error 1
make[1]: *** [crypto] Error 2
make[1]: Leaving directory `/usr/src/linux-source-2.6.17'
make: *** [debian/stamp-build-kernel] Error 2

Reply to: