[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

bind 8.4.7 and notifys



Hi!

While migrating a nameserver, I noticed a difference between BIND 8.4.6 
 (Debian -1) and 8.4.7 (also Debian -1) - the latter one doesn't send 
 NOTIFYs when a zone is changed&reloaded.

I tried explicitly setting "notify yes;", both globally and in the zone 
 definition, but still no luck:

options {
...
        notify yes;
        suppress-initial-notify no;
        };
...
zone "zone.invalid" {
        type master;
        file "master/zone.invalid";
        allow-transfer {secondarys; trusted_hosts;};
        notify yes;
};

If I configure logging for notify, severity debug, I get

notify: info: suppressing duplicate notify ("zone.invalid" IN SOA)

(And no, it simply doesn't send any NOTIFY whatsoever, verified with 
 tcpdump, the "suppressing duplicate" ain't true.)

Any hints? I can find no mention of this behaviour in the docs, nor on 
 bugs.d.o either. Both machines are sun4u, Sarge vs. Etch.

cheers+TIA,
&rw
-- 
-- '2001' muss bei mir wohl einen konditionierten Reflex ausgeloest
-- haben. Sobald ich einen 'intelligenten Assistenten' sehe, klappe
-- ich in Panik das Rechnergehaeuse auf und rupfe alle Steckkarten
-- heraus.                                             - Mirko Liss


Attachment: pgpS7eV83FYU5.pgp
Description: PGP signature


Reply to: