[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installing a Sunfire v480

Good Evening, 

I am trying to install debian stable on a sunfire v480, had tried different methods... none of them successfull. This machine has an UltraSPARC III cu proccessor.

I tried official debian sparc iso booting.:

>>>Rebooting with command: boot cdrom
>>>Boot device: /pci@8,700000/ide@6/cdrom@0,0:f  File and args: 
>>>SILO Version 1.4.9
>>>Allocated 8 Megs of memory at 0x40000000 for kernel
>>>Loaded kernel version 2.4.27
>>>Could not find any available memory
>>>Fatal error: You do not have enough continuous available memory for such 
>>>initial ramdisk.
>>>Program terminated
>>>{2} ok 
>>>WARNING: Power Supply 1 not receiving AC power.
didn't work, 
so i downloaded  debian-31r1a-sparc-businesscard.iso and debian-31r2-sparc-netinst.iso
this didn't work either..
then i tried net boot image with an image found in this page:


i used TFTP boot image sun4u net boot image and the sun4cmd image too, sun4u image 
with sun4cmd it gave me this errors..

	">sun4u you have to use UltraLinux (64bit) kernel
	and not a 32bit sun4[cdem] version "

with sun4u image:
	it gives me this message and stops...
	">Fast Instruction Access MMU Miss"

... for this somebody on #debian-sparc on freenode.net suggester a complete poweroff .. but tried it with no positive results....

Used an unofficial sid sparc iso:
>>>                 Welcome to Debian GNU/Linux sid!
>>>This is a Debian installation CDROM, built on 20060401.
>>>Keep it once you have installed your system, as you can boot from it
>>>to repair the system on your hard disk if that ever becomes necessary.
>>>WARNING: You should completely back up all of your hard disks before
>>>  proceeding. The installation procedure can completely and irreversibly
>>>  erase them! If you haven't made backups yet, remove the rescue CD from
>>>  the drive and press L1-A to get back to the OpenBoot prompt.
>>>Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent 
>>>by applicable law.
>>>[ ENTER - Boot install ]   [ Type "rescue" - Boot into rescue mode ]
>>>boot: rescue
>>>Allocated 8 Megs of memory at 0x40000000 for kernel
>>>Loaded kernel version 2.6.16
>>>Loading initial ramdisk (3258554 bytes at 0xA0FE002000 phys, 0x40C00000 
>>>Illegal Instruction
>>>{2} ok 

Then i read about other linux distributions that would possibly boot on this machine and gentoo was the first i heard of so i tried it the install-sparc64-minimal-2006.0.iso:

>>>>Type "config" to see the SILO config file.                                       
>>>>boot: gentoo                                                                     
>>>>Loading initial ramdisk....                                                      
>>>>bootmem_init: Scan sp_banks, init_bootmem(min[5000000], 
>>>>bootmap[50001d0], max[507fd99])
>>>>free_bootmem(sp_banks:0): base[a000000000] size[fe000000]
>>>>free_bootmem(sp_banks:1): base[a0fe002000] size[ffc000]
>>>>free_bootmem(sp_banks:2): base[a0ff002000] size[b2a000]
>>>>free_bootmem(sp_banks:3): base[a0ffb30000] size[2000]
>>>>reserve_bootmem(initrd): base[a0ffa22000] size[f7f75]
>>>>reserve_bootmem(initrd): base[a0ffa22000] size[a0ffb19f75]
reserve_bootmem(kernel): base[a000000000] size[39ea50]
>>>>reserve_bootmem(bootmap): base[a0003a0000] size[ffb8]
>>>>Remapping the kernel... done.

And then somebody did mention that ther was a debian-netbsd port , and since netbsd is an operating system that supports so many platforms i decided to qive it a try. But upon reading netbsd.org section on supported platforms , specifically the part of sparc64 I found a disturbing part at the end of the page that says:

Unsupported Hardware

    * Systems with an UltraSPARC III CPU
    * Systems with an UltraSPARC IIIi CPU
    * Systems with an UltraSPARC IV CPU
    * SMP (NetBSD/sparc64 currently only uses one CPU if more than one is present)
    * Floppy drives
    * smart card reader

I guess it's useless to try debian-netbsd port .. since not even netbsd alone supports this processor, besides this machine has no floppy drive and debian-netbsd install procedure relies on floppies...

Well i tried .... i read somewhere that using the .registers command after a message like 
">Fast Instruction Access MMU Miss" would help the debian-sparc port developers to spot the problem, if there is one.. It might also be i have been overseeing something obvious... 

Excuse my english, as it is my second language...
Can I help with these .registers stuff or have i been missing some trick to install debian on sunfire v480??????

Camilo Olarte
FluidSignal Group S.A.

Reply to: