[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#306476: quick question about Bug#306476

Hi Jim and Frans,

Thanks very much for the follow-up and suggestions. For the sake of creating a useful record I'll let you know what happened here.

I ended up getting this working using the standard sarge minimal-cd net installer, which was the thing that failed in the first place. To get it working, after the "detect and mount cdrom" phase failed, I went into a shell and did "modprobe esp". This then starts the in-built scsi card and detects the cdrom and hard disk. I then exited the shell, tried the "detect cdrom" step again, and the rest of the install proceeded normally. (I also needed to know that the network controller was a Happy Meal card).

To get to this point, I had also tried the latest etch cd installer which uses a 2.6 kernel. This installer failed at other points (I had to modprobe esp and it couldn't mount the disk after partitioning, and something else too...) but what was useful was that it told me that the module for the scsi controller was called "esp". Since this is an sbus system, not pci, there doesn't appear to be an equivalent of "lspci" which would have solved my problem immediately. (If there is such a thing, please let me know.)

So all's well that ends well. If you think that the failure to load the correct scsi driver modules during the "detect cdrom" phase is a bug, then I'll be happy to submit one.


P.S I did all this using the serial terminal on the back of the box since it has no graphics card. That works fine when connected to a terminal with minicom (in this case an Ultra10 running linux), but you must turn off all flow control.

Reply to: