[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Setting time time causes system crash

Work Around: I set the time using ntpd (ntpd -g 10000) in 10000 second steps
and it updated progressively to the correct time without a crash.  I suspect
that when I tried to update it in one step of more than 42000 seconds that
caused the crash.  FYI: Offsets greater than 1000 seconds cause ntpd to exit
without actually changing the system time and when I tried to manually set
it, I was making a 42000 second step.  Probably could have accomplished the
same thing in small manual steps of less than 10000 seconds.  Thanks for
response everyone, SUN+Debian ROCKS!

-----Original Message-----
From: Steve Discher [mailto:discher@fibertown.com] 
Sent: Thursday, December 15, 2005 9:48 AM
To: debian-sparc@lists.debian.org
Subject: Setting time time causes system crash

I am running a stock Debian Linux kernel 2.6.8-2-sparc64 on a Sun Netra T1.
If I set the system time using a time server via ntp or directly from the
command line it causes the system to lock up.  There are not entries in the
system log to evidence the cause.  Any ideas?  

hwclock --hctosys  and hwclock --systohc  don't seem to bother anything.  

Currently my system time is -42409 seconds off.  

To UNSUBSCRIBE, email to debian-sparc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

Reply to: