[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel panic: No init found?

You can try compiling a kernel yourself, that doesn't require an initrd.
Not sure if it will help, but it's worth a try.

On Tue, Jun 14, 2005 at 09:38:53PM +0000, Guy T. Rice wrote:
> I've tried installing sarge on a SPARCstation 20 a few times now,
> using the r0a CD image.  The installer works fine until you go to
> reboot the system, but when you reboot, the kernel panics with this
> error:
> Kernel panic: No init found. Try passing init= option to kernel
> I've tried init=/sbin/init and init=/bin/sh, neither of which works,
> despite the fact that if I look either at the root filesystem or the
> initrd filesystem (after loopback mounting
> /boot/initrd.img-2.4.27-2-smp) these files are present.
> Figuring that it might be an error in the initrd.img, I pulled one of
> the processors out of the machine to cause d-i to install a different
> kernel.  That fixed the problem.  However, now I'm not using an SMP
> kernel.  If I switch back to the SMP kernel and the problem reappears,
> is there some way to fix this short of reverting to the UP kernel?

Debian     - http://www.debian.org/
Linux 1394 - http://www.linux1394.org/
Subversion - http://subversion.tigris.org/
SwissDisk  - http://www.swissdisk.com/

Reply to: