[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Boot on RAID1

On Wed, 22 Dec 2004 10:35:12 -0500, Gabor Szilagyi
<Gabor.Szilagyi@nyo.unep.org> wrote:
> Hash: SHA1
> Hi Eduardo,

Hi, thanks for your reply

I've tried some of your tips and some from the Software RADIUS howto
and  I got it   working. But now I have another problem

>The trick I found working
> in that scenario was to _NOT_ include the first block (which is the 0
> when you do fdisk) into the first partition (which is boot for me). This
> is where the boot block and the partition info is (I think). When the
> two disks were not identical mirroring wrecked havoc on the partition
> table as well. Took me a long time to figure that.

I think you're right. My /boot is mounted on /dev/md0 wich is hda1 and
hdd1 and every time I boot the system I lose hdd's partition table

I've tried to start hda1 and hdd1 at the block 1 instead 0, but after
this, I can't boot anymore, i got the "The file just loaded does not
appear to be executable" message from the  EPROM

> I think the real trick is to make the whole disk partition bootable at
> the very beginning of the install process.

How can I do this? I don't want to reinstall the whole system.

> The booting starts from the Sundisk label partition and actually the
> prom is smart enough to read the image itself (not like x86). So the
> above silo.conf tells the prom to read an image from the first partition
> of the disk you are booting from. BUT the prom can only figure out ext2
> ext3 filesystem at this time (I believe) not reiserfs.
> In case let say your primary drive is dead ... you can safely go to boot
> prompt (like STOP-A) and type something like:
> boot disk2 and that will boot your system just fine.... I assume here
> that your raided drive was disk2 ... (in my case the secondary IDE
> master in an ULTRA 10).

Thanks in advance
Eduardo Gonçalves

Reply to: