[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't boot Sarge after install on Ultra 30.

On Sat, 18 Dec 2004, Chris Andrew wrote:

Hi all,
I'm having problems booting Sarge after install on an Ultra 30. The openprom comes up ok, then I get the message: "The file just loaded does not appear to be executable" I have also tried an old Woody disk and the same thing happened. The strange thing is, they have both booted fine, before (well maybe not this recent netinstall image of Sarge). I can install and run Red Hat 6.2, so this would seem to indicate that the problem was distro specific, not hardware specific.
Any thoughts?


This error message is usually displayed when you are trying to boot from a device, different from the one you've installed into. If you just issue a 'boot' command at the 'ok' prompt, the firmware will try to start SILO from the 'disk' pseudodevice, which is usually aliased to the first disk in the system (in my case - the first SCSI disk, with SCSI id 0). If you have installed the system elsewhere, you need to either give the 'boot' command an argument, specifying the location, like 'boot disk1' or 'boot disk2' to boot from other disks, or to modify the 'disk' alias using the 'nvalias' command. You can display currently defined aliases with 'devalias'.

If that does not solve you problems, please post a followup, containing the information about your device layout, partitioning scheme (including the filesystem types), exact specification of the installer media you are using and the boot commands you have tried.

Best regards,

Jurij Smakov                                        jurij@wooyd.org
Key: http://www.wooyd.org/pgpkey/                   KeyID: C99E03CC

Reply to: