[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem upgrading libc6



Joshua Kwan wrote:
On Sat, 29 May 2004 22:13:42 +0200, Magnus Hyllander wrote:
  
 subprocess pre-installation script killed by signal (Segmentation fault)

Errors were encountered while processing:

 /var/cache/apt/archives/libc6_2.3.2.ds1-12_sparc.deb
    

Oh, shit.

Wanna add -x to the 'set -e' in /var/lib/dpkg/info/libc6.postrm and see
what happens before it segs?

I'm fairly confident that once you find it, you could just add exit 0 to
the beginning of the script (past the hashbang) and stuff will work fine.
But it's nice to know. I figure ldconfig is segfaulting...

And if that works, see what happens if you ldconfig after the new libc6 is
unpacked.

HTH
  
OK, I tried this but I'm not sure if libc6.postrm is being run at all. I tried both adding "set -x" and "echo running postrm" to the script, but I don't see any output.

This is my first try at installing Debian and using apt-get and dpkg, so I'm sorry if I'm missing something obvious here.

/Magnus

Reply to: