[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RE: Broken keyboard in XFree86

Was this issue ever resolved? I am having the exact same problem except that 
when I ssh in to kill X, it does not give me any tty's back and the keyboard 
is still completely unresponsive (I have to reboot). The lights for Caps 
Lock, Num Lock, etc are even out and unresponsive. I can't figure it out. 
I've tried both XFree and Xorg. Currently I am on Xorg and I filed a bug 
report on it because I have searched and search to no avail.
Yes, the "ServerLayout" section has the line InputDevice "Keyboard0".  I 
simply modified the XF86Config-4 file that is generated by
"XFree86 -configure".  I have also tried the type5 option, and have also tried 
without any of the Option lines.  If nobody has even heard of this problem 
before there must be something I'm missing.


-----Original Message-----
From: Steve Pacenka [mailto:s.pacenka@verizon.net] 
Sent: Thursday, October 02, 2003 6:39 AM
To: Thurmond, Phillip
Cc: debian-sparc@lists.debian.org
Subject: Re: Broken keyboard in XFree86

On Wed, 2003-10-01 at 09:42, Thurmond, Phillip wrote:
> I have a newly installed debian (unstable) system.  So far, I canÿt
> get X to work.  The mouse and display work fine, however the keyboard
> is completely unresponsive.  The machine doesnÿt even respond to
> ctrl-alt-del, stop-a, or ctrl-alt-bspc.  If I ssh in and kill the X
> server, Iÿm dropped to a console at which point the keyboard works
> fine again.  Iÿve seen many messages about problems with keymaps, but
> none where the keyboard just didnÿt work at all.  If anyone could help
> Iÿd appreciate it.

> Here is the relevant section from my XF86Config-4.  Iÿve tried it with
> and without the ´Option¡ lines.
> Section "InputDevice"
>         Identifier  "Keyboard0"
>         Driver      "keyboard"
>         Option "CoreKeyboard"
>         Option  "XkbRules" "sun"
>         Option "XkbModel" "type6"
>         Option "XkbLayout" "us"
> EndSection

Just to make sure, does this file also refer to that keyboard spec in
the ServerLayout section:

Section "ServerLayout"
    InputDevice "Keyboard0"

And have you tried other keyboard types, like "type5"?  I'm not sure
what type my U10's keyboard is, but it's newer than Type 5s I own and I
still use the type5 model in XF86Config-4.  I don't remember having a
type6 choice (in this case 4.2.1-6) during setup.

-- good luck, SP

Reply to: