[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Ultra5 + Linux kernel 2.6.1 = hangs while booting

Hi Everyone,

I currently have version 2.4.18 #2 of the kernel, which came when I
installed woody for Sparc.  Everything is 'stable', except for gcc and
related packages which were upgraded to 'testing' (gcc 3.3.2).  I have been
trying to compile a version of 2.6.1 for over a week with lots of problems
and I'm finally stuck, exhausting the web and forums, and need some help.  

I have tried endless .config permutations, the most promising being the 2.6
Ultra10 example from:


It seems like a lot of people like me have trouble with the size of the
kernel, and I can't ever use vmlinux, even compressed, so I follow these

make menuconfig
make image
make modules
make modules_install

The arch/sparc64/boot/image is then placed in /boot (along with the new
/boot/System.map) and added to silo.conf.

Whenever I try to boot to this from silo, I get:

	boot: linux6
	Loaded kernel version 2.6.1

	Remapping the kernel... done.
	Booting Linux...

Where it flashes the keyboard LEDs once, then appears to freeze
I have tried many of the graphics modules, but is there one I need
specifically?  How will my Ultra5 config need to be different from the
Ultra10?  Should I go back to a 2.6 instead of 2.6.1?

Any ideas would be truly appreciated; I'm just tired of compiling.


	Alex Smith

Reply to: