[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SILO Fun (Was: Re: Seems to be working (Was: Re: Debian and IPX))

At 13:30 -0500 11/29/03, Ben Collins wrote:
On Sat, Nov 29, 2003 at 01:11:32PM -0500, Mauricio wrote:
 At 22:04 -0500 11/28/03, Ben Collins wrote:
 >On Fri, Nov 28, 2003 at 06:06:40PM -0500, Mauricio wrote:
 >>	I just finished installing debian in my IPX.  Well, almost.
 >> When it is the time to make the disk bootable, this is the message I
 >> am getting:
 >> "SILO wasn't able to install. You'll still be able to boot your
 >> system if you create a boot floppy, but it won't be able to boot
 >> without a floppy."
 >> What could be causing that and what can I do?
 >Can you show me the partition map from fdisk?

 You mean this:

   /dev/sda1            1    102      49M  ext3        /boot
/dev/sda2 103 899 382M ext3 / /dev/sda4 900 6175 2534M ext3 /usr /dev/sda5 6176 8104 926M ext3 /home
   /dev/sda6         8105   8637     256M  ext3        /var
   /dev/sda7         8638   9006     177M  swap

You do have a "Whole Disk" partition on sda3, right?

	Do I have to physically create one or it is assumed to be there?

If you are doing the /boot seperate, it really isn't supported
automatically unless you use the images I posted about. Otherwise,
you'll need to do this at a prompt before rebooting the install:

cd /target
mv etc/silo.conf boot/
ln -s . boot/etc
ln -s . boot/boot
ln -s ../boot/silo.conf etc/silo.conf
cd /
silo -r /target -f

	How about if I then repartition the HD as follows:

   Device Flag    Start       End    Blocks   Id  System
/dev/sda1             0      8208   4038336   83  Linux native /
/dev/sda2          8209      8741    261744   83  Linux swap   swap (256MB)
/dev/sda4          8742      9006    129888   83  Linux native /var (128MB)

I did so and ended up having the very same problem. So, I dropped to the shell and did as you suggested above. I did not go that far:

SPARCstation IPX, No Keyboard
ROM Rev. 2.9, 48 MB memory installed, Serial #12648430.
Ethernet address 8:0:20:c0:ff:ee, Host ID: 57c0ffee.

Rebooting with command:
SCSI device 2,0 is not responding
Boot device: /sbus/esp@0,800000/sd@3,0   File and args:
SILO Buggy old PROMs don't allow reading past 1GB from start of the disk. Send c
omplains to SMCC

Read error on block 262148 (tried 4096, got -1)

Cannot find /etc/silo.conf (Unknown ext2 error)

Couldn't load /etc/silo.conf
No config file loaded, you can boot just from this command line
Type [prompath;]part/path_to_image [parameters] on the prompt
E.g. /iommu/sbus/espdma/esp/sd@3,0;4/vmlinux root=/dev/sda4
or 2/vmlinux.live (to load vmlinux.live from 2nd partition of boot disk)

Reply to: