[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sparc32/64 kernel 2.6.0-test1

On Sun, Jul 20, 2003 at 02:38:07PM -0400, Ben Collins wrote:
> On Sun, Jul 20, 2003 at 12:32:56PM -0600, Otto Solares wrote:
> > Hi ppl,
> > 
> > i managed to compile linux-2.6.0-test1-ac2 (linux-2.6.0-test1-mm* series
> > don't compile at all) but when trying to boot it gets an error about
> > image too long, indeed the image size is much longer than 2.{2,4} used
> > to be, is a kernel with the basics to boot and everything as modules,
> > so i try to strip vmlinux and now i get a "cannot find a loadable
> > segment in your ELF image" error when booting, any idea how to boot
> > this beast on sparc32 hardware? on sparc64 i get a freeze on boot...
> > i googled and find that osinvestor.com/sparc32 have patches for
> > sparc32 BUT is down :(   i read too that sparc32 has no maintainer
> > at all :(    sad because i got a lot of sparc32 boxes and i want
> > 2.6 support on it (that's why i am testing)...
> > 
> > hardware:	arch	problem:
> > ss4 (sun4m)	sparc32	image size too long
> > ultraE1 (sun4u)	sparc64	freeze inmediately on boot
> > netrat1 (sun4u)	sparc64	freeze inmediately on boot
> > ultra250(sun4u)	sparc64	freeze inmediately on boot
> > classic (sun4c)	sparc32	image size too long
> > 
> > all sparc32 boxes with sid and sparc64 with woody.
> "make image" and then user arch/sparc64/boot/image to boot with instead
> of vmlinux.

thanks for the quick response!

ok, i will test it now, "make image" works for both sparc32/64?

> Also, what compiler are you using? It had better be gcc-3.2.3 (latest in
> unstable).

i try with both gcc-3.2.3 and gcc-2.95.4 on sparc32, on sparc64 only


Reply to: