[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Upgrade of kernel to 2.4.18 fails


I would like to run this build, but this is the only SPARC 5 and it is a
firewall for a small network and I do not want a compiler on a firewall.
What would be an other way I can do this?


-----Original Message-----
From: Ben Collins [mailto:bmc@phunnypharm.org]On Behalf Of Ben Collins
Sent: Thursday, July 03, 2003 3:29 PM
To: David Demland
Cc: debian-sparc@lists.debian.org
Subject: Re: Upgrade of kernel to 2.4.18 fails

On Thu, Jul 03, 2003 at 12:18:08PM -0700, David Demland wrote:
> I just did an apt-get of the new 2.4.18 kernel. During the install of the
> package there was an error about not being able to run modprobe. I allow
> install to abort the first time, then I tried it a second time, this time
> without the abort. In both cases when SILO goes to start I get the
> error:
> SILO boot:
> Uncompressing image...
> /
> Decompression error: uncompressed image too long - wouldn't fit into
> destination
> Error loading /vmlinuz
> Image not found.... try again
> Any idea on what I have to do to fix this?

modularize, or strip the kernel image, or build 2.4.21 and do "make
image" and use the file arch/sparc64/boot/image. You really shouldn't be
using 2.4.18 on sparc64. It's way less stable than 2.4.21.

Debian     - http://www.debian.org/
Linux 1394 - http://www.linux1394.org/
Subversion - http://subversion.tigris.org/
Deqo       - http://www.deqo.com/

Reply to: