[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Help with Sparc 20 boot problems

Good morning.

After going back and repartitioning (after formatting, SILO install,
etc), I am stuck at the following boot error. Note to self: Never
repartition, no matter how many second thoughts I may have after a good
nights sleep.

SILO on sda is grabbing the boot cycle and failing, of course, since
I've repartitioned without reformatting (the install software said a
reboot was required before formatting could take place).

Ok, just now I tried the absurd: I typed "halt" at the SILO "boot:"
prompt, and got an "ok"! So "boot floppy" is now happily loading.

I will continue from this point, with the new partition style (this is
the first time I've seen "Whole Disk"), and let y'all know what the
final results are.


Here was the entire boot message, because I already had pasted it into
this email.

Boot device: /iommu/sbus/espdma@f,400000/esp@f,800000/sd@1,0  File and
args: -v
SILO Buggy old PROMs don't allow reading past 1GB from start of the
disk. Send C
Read error on block 851972 (tried 4096, got -1)

Cannot find /etc/silo.conf (Unknown ext2 error)

Couldn't load /etc/silo.conf
No config file loaded, you can boot just from this command line
Type [prompath;]part/path_to_image [parameters] on the prompt
E.g. /iommu/sbus/espdma/esp/sd@3,0;4/vmlinux root=/dev/sda4
or 2/vmlinux.live (to load vmlinux.live from 2nd partition of boot disk)

You have `-v' string in your boot-file variable.
This string doesn't contain valid arguments to SILO.
Consider doing setenv boot-file. Anyway, SILO will continue as
if there were no arguments in boot-file.
boot: ls
Your imagename `ls' and arguments `' have either wrong syntax,
or describe a label which is not present in silo.conf
Type `help' at the boot: prompt if you need it and then try again.

"Wherever I go, everyone is a little bit safer because I am there.
 Wherever I am, anyone in need has a friend.
 Whenever I return home, everyone is happy I am there."
   ---The Warrior Creed, Robert L. Humphrey, USMC

Reply to: