[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: boot-floppies 3.0.21 for testing

On Sat, 16 Mar 2002, Joshua Uziel wrote:

> * Adam Di Carlo <adam@onshore-devel.com> [020316 10:25]:
> > "Thomas J. Zeeman" <tjzeeman@cs.vu.nl> writes:
> > > I tried to do a floppy-install but for reasons I couldn't figure out, due
> > > to a lack of working and accepted floppies, it failed on me.
> > > The tftpboot.img worked. No other options tried.
> >
> > That's bad.  Does it work in the 3.0.20 version in the archive?

The 3.0.20-version is flawwed fatally: it lacks RAMfs-support in the
kernel. The only version of bf I've managed to get working with floppies
was the 3.0.18-version from BenC from last november. Haven't tried any
version before 3.0.16 though, only have the Ultra1 since early Februari.

> > In any case, you should follow this up with a bug in the boot-floppies
> > packages with any details, onscreen messages, etc.
> Thomas - you're trying a floppy install on an Ultra?  A lot of Ultras
> have a firmware bug that breaks floppy booting.  Just be sure that you
> can get floppy booting to work with any disks before you start yourself
> on a wild goose chase.

I've managed to install this U1 from floppies before. IIRC U1 and possibly
U2 are the only type of Ultras not affected by the bug you mention.
I've been told that from U5 and up booting from floppy isn't gonna work.
If that's because of the bug or not, haven't got a clue.

Then again, the 3.0.21 isn't working either. The RAMfs is built into the
kernel this time, but after changing the disk it freezes so hard it needs
a power-cycle (Stop-A didn't work :( ). No drive activity after I've
pressed enter to confirm the change of disk. Just a screen with the nice
logo of Tux with a sun on its belly and the kernel boot output.
(Just curious, but why does a sun-kernel-image have RTC enabled? Have they
introduced these in very recent machines?)

The last two messages are:
floppy0 WARNING disk change called too early
and then a the message to put in the root-disk and press ENTER.

Doing that results in the mentioned freeze.

Considering the U1s are esentially the only ultras even capable of booting
from floppy and even that is troublesome - I've had to go through at least
a dozen working (!) floppies to find one that would get accepted by the
drive + OpenBootPROM - I don't know if it is even worth it to try to get
this to work. Most other people seem quite content with having a
choice of either a bootable cd or a tftp-boot.
I'm willing to help out on this, but unforseen RL-happenings put my
efforts on this matter on hold until at least next weekend. :(


	Every luxury must be paid for, and everything is a luxury,
	starting with being in this world.

	 -- Cesare Pavese

Reply to: