[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

problems installing Woody on Ultra1

hi all,

yesterday I installed Woody on an Ultra1 (140 MHz, 128 MB, OpenBoot PROM
3.25, 1 * 2 GB disk, 1 * 4 GB disk, Yamaha CD-rewriter, floppy) and some
things went wrong. I used the CD images from here:

I used the sparc images from Feb 3. The CD could not boot, because it could
not find the root file system (tried to mount it on 0b:00 if I remember
correctly, not sure).
I then used bootfloppies (old Ultra, so it works) and that worked, partly.

First, I tried it all the way with floppies, but after loading root.bin
and some config options I was asked to insert the rescue floppy again and
it tried to extract the rescue image. This failed. Installing the base
system from CD also did not work (CD could not be mounted).
So I copied over everything from CD to disk and told the installed it
should use a "previously mounted partition". So far, so good, the installer
started to install. I had mounted my old Mandrake root partition all the
time and after installing the packages nothing happened, except on the
debug screen. Messages about which timezone or locale I wanted (not sure
it went too fast) flew over the screen. Actually I had expected that message
on the main screen, not on the debug screen.

So, reinstall, but with my / unmounted. Everything went beautifully. SILO
ran, everything was installed, rebooted and then I got this.

SProgram terminated

Apparently SILO didn't come past the "S". I tried a lot of stuff (trying
some SILo options), but it didn't help. Eventually I booted the rescue
floppy and set root=/dev/sd1 and the installation continued and now I've
got a Woody on Sparc. I'm pretty much impressed by the installer and
everything, because, apart from the problems, it went really smooth.
But still, SILO is not working, which isn't nice.

If you need more information that can help you I can get it (but the machine
is at home, no connectivity there, so I cannot get it very fast). I am
prepared to do more installs from CD and floppy until it works, it's just a
test machine...


   armijn@nl.linux.org | http://people.nl.linux.org/~armijn/ | Penguin Power
                 http://nl.linux.org/ | Alles over Linux

Reply to: