[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

leo/zx driver toast in X11 4.1 ?

i recently upgraded my ss20 from stable to unstable and moved to
x11 4.1. according to the docs, and what not the driver exists and
works. unfortunately, when i run x, regardless of depth i get: 

(II) SUNLEO: driver for Leo (ZX)
(--) Assigning device section with no busID to SBUS:/iommu@f,e0000000/sbus@f,e00
(II) resource ranges after probing:
        [0] -1 0        0xffffffff - 0xffffffff (0x1) MX[B]
        [1] -1 0        0x00000000 - 0x00000000 (0x1) MX[B]
        [2] -1 0        0x00ffffff - 0x00ffffff (0x1) IX[B]
        [3] -1 0        0x00000000 - 0x00000000 (0x1) IX[B]
(EE) SUNLEO(0): Given depth (24) is not supported by this driver  
(II) UnloadModule: "sunleo"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
24bpp is supported, so i am unsure of what the problem here is. i ran x3.3.x
for a long time with no problems, and run x4 on serveral machines - so i do
not think it is a configuration error.

i have leo framebuffer support built into my kernel, and im using a recent
vger 2.2.


  john wood

  systems administrator, gmo inc 

Reply to: