[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: latest update from woody

On Thu, 9 Nov 2000 at 10:30pm, Ben Collins wrote:

BC> > HOST: ~ >> ldd /usr/lib/R/bin/R.bin 
BC> >         libreadline.so.4 => /lib/libreadline.so.4 (0x5002d000)
BC> >         libz.so.1 => /usr/lib/libz.so.1 (0x50069000)
BC> >         libdl.so.2 => /lib/libdl.so.2 (0x50088000)
BC> >         libncurses.so.5 => /lib/libncurses.so.5 (0x5009c000)
BC> >         libm.so.6 => /lib/libm.so.6 (0x500f6000)
BC> >         libf77blas.so.2 => not found
BC> >         libcblas.so.2 => not found
BC> >         libatlas.so.2 => not found
BC> >         libc.so.6 => /lib/libc.so.6 (0x50137000)
BC> >         /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x50000000)

BC> If this only affects blas, then I suspect blas is at fault. Did you
BC> try running ldconfig as root? Try running "ldconfig -p | grep
BC> libf77blas.so". To be honest, that symlink mess may be the problem.
BC> There is no reason for two soname links (IOW, kill the one in
BC> /lib).

I ran ldconfig and again just now (after removing those 
extra libs in /lib).  Same result as above.   :(

BC> Partial upgrades to XF4 are going to cause some issues, I'm sure.
BC> If you feel really bold (and from the looks of it, you seem to like
BC> punishment :) try install xserver-xfree86 and configuring the new
BC> Xserver.

I was concern about that partial update too ... .  But I 
really didn't know what is necessary or not necessary 
that evening since there wasn't any dependency problem 
(or otherwise I wouldn't have wanted to continue).   :(

I do feel bold when I have time.  :)    Is there anything 
special about this newer X stuff that I will need to know 
first?  I mean sparc related ... I think you have mentioned 
sometime ago in this list that we now can do Xconfig stuff 
like in the x86---so you see, I am a little timid now ... 
I couldn't even able go into the archive to verify this  :(

Thank you very much for your quick response!


Reply to: