[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

problems installing sendmail

Hi all,

This week i've taken it upon me, to re-install an old sparc IPC using
All went fine (took a couple of days, because I wasn't there when I had to
hit [ENTER] (or other config-stuff...), but that's all)
Anyway, today it was sendmail's turn, but help, it segfaults when running
/usr/share/sendmail/updatedb at the end of the config-part.
I 've tried it a couple of times, but it keeps segfaulting.
On i386 this doesn't happen (just tried...), so it has to do something
with the sparc-version.

Any thoughts ??
(I know I don't...)

hardware: sparc IPC
software: Debian GNU/Linux potato (apt-get update ; apt-get upgrade)
sendmail: 8.9.3-21

Further info (dump of the install-process), is provided below.

Taco IJsselmuiden.

----------------------- use chainsaw here ----------------------
sparcy:~# apt-get install sendmail
Reading Package Lists... Done
Building Dependency Tree... Done
The following NEW packages will be installed:
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 949kB of archives. After unpacking 2494kB will be used.
Get:1 ftp://ftp.nl.debian.org frozen/main sendmail 8.9.3-21 [949kB]
Fetched 949kB in 3s (245kB/s)    
Selecting previously deselected package sendmail.
(Reading database ... 33735 files and directories currently installed.)
Unpacking sendmail (from .../sendmail_8.9.3-21_sparc.deb) ...
Setting up sendmail (8.9.3-21) ...
Stopping mail transport agent: sendmail.

You are doing a new install, or have erased /etc/mail/sendmail.mc.
If you've accidentaly erased /etc/mail/sendmail.mc, check /var/backups.

Sendmail will not start until it is configured.
Do you wish to configure sendmail now, or wait until later?

Configure now ? (y/N) y

<...skip config-questions: answered them all using defaults...>

Updating sendmail databases ...
Checking sendmail.cf and databases.
Scanning /etc/mail/sendmail.mc
Creating /etc/mail/Makefile..... done.       
Generating /etc/mail/sendmail.cf ...
/usr/share/sendmail/updatedb: line 27:  3318 Segmentation fault      m4 /usr/share/sendmail/sendmail.cf/m4/cf.m4 /etc/mail/sendmail.mc >/etc/mail/sendmail.cf.new 2>/etc/mail/sendmail.cf.errors
Start sendmail now? (Y/n) 
Starting mail transport agent: 451 /etc/mail/sendmail.cf: line 0: cannot
open: No such file or directory
dpkg: error processing sendmail (--configure):
 subprocess post-installation script returned error exit status 72
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

----------------------- use chainsaw here ----------------------

Reply to: