[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

still not booting

First, I'll answer my own question:

> (And how many kinds of incompatible partition table are there?)

The answer is quite a lot. See check_partition() in
linux/drivers/block/genhd.c for a list of the ones that Linux can

I managed to convert my previous partition table (I don't know what
type it was) to a Sun partition table while preserving the ext2 file
system in /dev/sda2; /dev/sda1 got trashed, but that was only swap,
fortunately. In general you can't always convert a partition table from
one type to another because the different types have different rules
about where a partition may begin. And there are all sorts of problems
with changing geometries ...

Therefore, the installation instructions should contain a clear warning
about making sure that you use a Sun partition table. Otherwise the
PROM will refuse to boot from that disc. Ideally dinstall/dbootstrap
should warn you if you try to use a different kind of partition table
but I assume it's too late to change that for slink.

Having said that, I still can't boot. This time the error message, when
I type "boot disk3" or equivalents, is something to the effect of "The
file loaded does not appear to be executable".

I ran silo beforehand with /etc/silo.conf as supplied by
dinstall/dbootstrap, and silo gave no error.

Any suggestions?


Reply to: