[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Errors compiling kernel-source-2.2.1 package

Jake Griesbach <griesbac@gamera.colorado.edu> writes:

> Sorry, I should have also mentioned that I get the same error compiling
> both the 2.2.1 kernel and the 2.2.2 kernel.  For the 2.2.1 kernel I used
> the debian kernel-source-2.2.1 package which (I think) has the neccessary
> patches.

I'm leaving david in the CC so he knows what is going on.

The kernel-source-2.2.1 package contains the official kernel source
(e.g. Linus's source).  It doesn't contain any sparc patches.  There
is a seperate package which contains the patch for sparc, and it is
automatically applied by our kernel building script if it is

IMHO, your best bet would be to download the patch for the 2.2.1
kernel from


and apply it to the 2.2.1 kernels source.


Reply to: