[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

sparc debian broken: Help urgent

	I just upgrqaded my sparc debian (somewhat unstable but
usable) to the latest version and now it is broken.
	First I have unwisely tried the unstable branch, I got a bunch 
of error related to glibc and finally dselect exit leving the machine
in an unusable state. Then I notice that there is sid brancch which
seem to be more stable. I reinstall the distribution from scratch,
there are still some installation errors but the most seriously

kbd is of version 0.96a-11 while kbd-data is of version 0.96a-12. As a
result dselect refuses to install kbd. At first I dont know why, but
when I tried to install kbd by hand I see the error message saying
that kbd requires kbd-data of vession = 0.96a-11 (it wants = and not >=

Now, without kbd, I can't run X: I got the error message

can't open /dev/kbd error no 2

Since I use this machine as an X terminal, without X, it is useless.

Another potential problem is that there is no /dev/sunmouse either. I
notice this when I tried to configure gpm. There is a link /dev/mouse
--> /dev/sunmouse but no file /dev/sunmouse. So I don't have gpm and I
suspect I will not be able to run X without /dev/mouse either.

	Now I am stuck with an unsuable machine. I cannot revert to
the old slink distribution (for sparc) since it is gone.
	Can anyone help me out ? If I can't get X running quick, the
only way I can do is to try to install redhat.

PHAM Dinh Tuan                         | e-mail: Dinh-Tuan.Pham@imag.fr
Laboratoire de Modelisation et Calcul  | Tel: +33 4 76 51 44 23
BP 53, 38041 Grenoble cedex (France)   | Fax: +33 4 76 63 12 63

Reply to: